Notification of BrokerBay Issue - Web & Mobile

Incident Report for BrokerBay

Resolved

Dear BrokerBay User,

The earlier issue with the BrokerBay Platform has been resolved. We apologize for any inconvenience this has caused you or your members.

Please reach out to us at support@brokerbay.com with any questions.

Thank you,
The BrokerBay Team
Posted Mar 23, 2025 - 12:59 EDT

Monitoring

Dear BrokerBay User,

We would like to provide you with an update regarding the earlier issue affecting the BrokerBay Platform & Mobile App. We have identified the root cause and implemented a priority adjustment to resolve the issue.

We will now closely monitor the situation to ensure no further adjustments are needed. Please reach out to us at support@brokerbay.com with any questions.

Thank You,
The BrokerBay Team
Posted Mar 23, 2025 - 12:32 EDT

Investigating

Dear BrokerBay User,

We are aware of a newly-reported issue that adversely affect user experience with the BrokerBay Platform & Mobile App. We are investigating and will follow up with more details as they become available.

Please reach out to us at support@brokerbay.com with any questions.

Thank you for your patience,
The BrokerBay Team
Posted Mar 23, 2025 - 12:09 EDT
This incident affected: BrokerBay System (Platform, Mobile App, Chat System).