We would like to provide you with an update regarding the earlier issue affecting access to the BrokerBay platform, including the website and mobile app. During the overnight hours, our technical team identified the root cause and implemented a priority adjustment to resolve the issue for all users in all markets.
We will now closely monitor the situation to ensure no further adjustments are needed. Please reach out to us at support@brokerbay.com with any questions.
Thank You, The BrokerBay Team
Posted Jul 16, 2025 - 08:11 EDT
Update
Dear BrokerBay User,
The BrokerBay platform, including the website and mobile app, is currently experiencing an access issue.
This may result in you and your members experiencing difficulties logging into BrokerBay directly, either at edge.brokerbay.com or via the mobile app. Please note this does not impact single sign on or other non-direct login methods available through the MLS to licensed users. Our team is still working to identify a solution to resolve this as quickly as possible.
We will provide an update on any changes and when the issue is resolved. Please reach out to us at support@brokerbay.com with any questions.
Thank you for your patience, The BrokerBay Team
Posted Jul 15, 2025 - 17:46 EDT
Identified
Dear BrokerBay User,
The BrokerBay platform, including the website and mobile app, is currently experiencing an issue. This results in your and your members experiencing difficulties logging into our platform. Our team has isolated the cause and is now working to identify a solution to resolve it as quickly as possible.
We will provide an update on any changes and when the issue is resolved. Please reach out to us at support@brokerbay.com with any questions.
Thank you for your patience, The BrokerBay Team
Posted Jul 15, 2025 - 11:27 EDT
Investigating
Dear BrokerBay User,
We are aware of a newly-reported issue that may adversely affect user experience with the BrokerBay platform, including the website and mobile app. We are investigating and will follow up with more details as they become available.